[Closed] 404 page not found after types update

Home Forums Paid Support [Closed] 404 page not found after types update

This topic contains 16 replies, has 5 voices, and was last updated by  William 1 year ago. The support staff assigned to this topic is Adriano.

Viewing 15 posts - 1 through 15 (of 17 total)
Author Posts
Author Posts
March 11, 2013 at 10:02 am #61897

Dirk

after updating types to 1.2 the view templates are not shown anymore. I only get the "page not found" error. I get the same error when I click "preview" in views->settings->view templates for post types. I also updated views to 1.2. No error with types 1.1

March 11, 2013 at 2:05 pm #62019

Adriano
Forum moderator

Dear Dirk,

Do you mean when access Types > Content Templates in the wp-admin? It's happens when you access Types > New Content Template too?

March 11, 2013 at 6:23 pm #62166

Dirk

Dear Adriano,
yes, I made a new view template, assigned it to the post type and still get the same error

March 11, 2013 at 6:41 pm #62180

Adriano
Forum moderator

Dear Dirk,

Please try to delete the wp-types folder and then update it manually by FTP. Download it in the http://wp-types.com/my-account/downloads/

March 12, 2013 at 8:53 am #62432

Dirk

Dear Adriano,
still the same error after the download. Another theme and deactivating all other plugins didn't help either. I created a new post type and view with the same results. Just to make sure, I reinstalled types 1.1.3 and everything worked. . Maybe views 1.2 has got something to do with the problem. Can I download the old version somewhere?

March 12, 2013 at 9:50 am #62452

Dirk

Dear Adriano,
deleting all views and custom post types finally helped, but unfortunately this is not an option for the production system. I would be willing rebuild the production system if I were able to export types and views. But exporting fails with the well known open_basedir error, which has been a topic several times in this forum. I cannot get it to work in my shared hosting environment. Is there any other way to export/import the types and views?

March 12, 2013 at 1:49 pm #62545

Adriano
Forum moderator

Dear Dirk,

Definitly it isn't a production way. Is the debugging mod active? http://wp-types.com/documentation/user-guides/debugging-types-and-views/

March 13, 2013 at 4:39 pm #63073

Dirk

Hi Adriano,
debugging according to the link you sent me, din't help. No error to see anywhere. Would it help if I sent you an sql dump or the whole installation?

March 13, 2013 at 5:09 pm #63087

Adriano
Forum moderator

Dear Dirk,

I’ll send you a private email right now asking you for some private information that will help me debug this issue for you. Please check your email in a couple of minutes, and if you don’t get it, let me know so I can send it again.
Thanks.

March 14, 2013 at 8:13 am #63362

Dirk

Dear Adriano,
the problem has got something to do with the permalink settings. It works with the standard permalinks like "url/?page_id=123". Any other permalink structure with the postname included produces the error.
I hope this helps, but I will prepare your system access anyway.

March 14, 2013 at 10:41 am #63402

Roy

I am experiencing the exact same problem. One specific kind of custom post type created with Types doesn't seem to work anymore. The others work fine. Also if I put the permalinks to standard it seems to work, just like in Dirk's case.

I've tried the suggestions given above as wel ass some I found in other threads on the public forums, but nothing seems to work so far.

Regards,

Roy

March 14, 2013 at 5:26 pm #63546

Adriano
Forum moderator

Dear Dirk,

I'm waiting the credentials, please send to adriano.f@icanlocalize.com

March 17, 2013 at 11:49 am #64929

antoninB

Hello

I think I'm facing the same situation as above since last Types update :
All my links to custom content types lead to "Page not found". If you want to experience it live : http://ec2-54-234-225-196.compute-1.amazonaws.com/
(PS : Only Actualités content types are basic WordPress posts)

I activated DEBUG in wp-config.php, seems PHP only throws one error : Notice: Trying to get property of non-object in /Users/antoninbrunon/Documents/gd/vivonslimmobilier/www/wp-includes/post-template.php on line 29

/**
* Retrieve the ID of the current item in the WordPress Loop.
*
* @since 2.1.0
* @uses $post
*
* @return int
*/
function get_the_ID() {
return get_post()->ID;
}

I don't think this error is Types-related.

So basically, no error generated by Types plugin. I'm lucky this project is still under development ! :)

March 18, 2013 at 10:45 am #65360

antoninB

Hello,

I rolled back to the previous version of Types and everything is working just fine.
Following that issue till it's resolved.

Cheers

March 18, 2013 at 1:15 pm #65429

Roy

The previous version of Types is working for me too. Rolled back a couple of days ago.

Viewing 15 posts - 1 through 15 (of 17 total)

The topic ‘[Closed] 404 page not found after types update’ is closed to new replies.


Support Policy
ToolSet staff will help you use Types, Views and CRED correctly, provide any information you need, help troubleshoot problems and advice on best-practices.
Please make sure to issue only one topic per each support ticket.
Need custom programming work for your site? Check out our certified partners.