Home Forums Paid Support [Resolved] Blank page when adding new post type

[Resolved] Blank page when adding new post type

This topic contains 24 replies, has 4 voices, and was last updated by  Lewis 1 year, 10 months ago. The support staff assigned to this topic is luoy.

Viewing 10 posts - 16 through 25 (of 25 total)
Author
Posts
#29878

As I explained before, I have done the debugging thing. My wp-config has this in it:

define('WP_DEBUG', FALSE);

define('WPV_LOGGING_STATUS', 'info');
ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

<strong>Nothing appears in the error console, or in the error log. We have a server error_log and nothing from this has appeared there either. </strong>

I've done various experiments and so I know it's not the plugin, I know it's something to do with our server. I just need some help as to what could be causing it, so we can fix it.

The page isn't posting the variables to the URL:

If I create a post type in my wp-admin I get the URL /wp-admin/admin.php?page=wpcf-edit-type when I press save.
If I do the same thing on discover-wp, I get the URL: /wp-admin/admin.php?page=wpcf-edit-type&wpcf-post-type=tests&wpcf-rewrite=1

#29884

luoy
Forum moderator

Hi Lewis, I have sent an email to our main developer about this problem, we will update this thread ASAP.

#29885

Thanks. If you need it, I emailed you info for an admin account on the WP install.

#29897

bruce
Forum moderator

Hi Lewis,

What other plugins do you have active?

Can you look in the DB options table for wpcf-custom-types. Is anything saved there?

The last thing Types does is to flush_rewrite_rules before re-directing to /wp-admin/admin.php?page=wpcf-edit-type&wpcf-post-type=tests&wpcf-rewrite=1

Best regards,
Bruce

#29898

Hi Bruce

Thanks for your post. It can't be a plugin issue as it does the same on clean installs. We've done an experiment today and installed it onto a different server and it works fine. It's clearly some kind of configuration issue with our server. It worked fine last week, but we changed some php config. We changed the file back to its original state but that doesn't seem to have helped.

I'd be interested to know which settings could potentially cause this kind of issue, so we can take a look at the server config.

Thanks
Lewis

#29990

luoy
Forum moderator

Lewis, I think you server did not enable PHP function mb_ereg, you need install it:
http://php.net/manual/en/mbstring.setup.php

#30094

This solution worked for us. After enabling this PHP function, we were able to add new types/taxonomies. Thanks.

#30191

Just to double check Predrag, is this causing issues with your WP install? We had mbstring enabled before but it caused issues when we used special characters in posts like the £ sign.

#30223

luoy
Forum moderator

Lewis, Is this problem resolved? Please let me know if you need more assistance.
Thanks

#30224

Hi Luo,

Thank you for your advice, it worked and with a small change to our php.ini we also avoided the special character issue.

Thank you for your help, along with both Bruce and Predrag.

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.

Support Policy

ToolSet staff will help you use Types, Views and CRED correctly, provide any information you need, help troubleshoot problems and advice on best-practices.

Please make sure to issue only one topic per each support ticket.

Need custom programming work for your site? Check out our certified partners.