[Closed] Post type with child relationship is redirecting

Home Forums Paid Support [Closed] Post type with child relationship is redirecting

Tagged: ,

This topic contains 13 replies, has 3 voices, and was last updated by  Adriano 1 year, 4 months ago. The support staff assigned to this topic is Adriano.

Viewing 14 posts - 1 through 14 (of 14 total)
Author Posts
Author Posts
March 27, 2013 at 8:28 pm #70145

Daniella

Hi,
I have a custom post type, Listings, and I just created a child called Additional Locations since there will be some businesses with more than one location. I set it up as a parent/child relationship based on the documentation. I created a Content Template with the necessary custom fields and a View (see screenshots). I added the following line into my main view template for displaying the info: [wpv-view name="Additional Location View"]
The first time I tested a Listing it worked. When I refreshed the screen to test something the url redirected to the child custom post type. I have attached screenshots as well.
Please help me (I did all of this work twice already!).
Thank you.

March 28, 2013 at 12:39 pm #70477

Adriano
Forum moderator

Dear Daniella,

Please let me see what plugins you are using now. We need to know if you are using some redirect plugins.

March 28, 2013 at 5:13 pm #70622

Daniella

Yes. The site uses this Redirection plugin: http://urbangiraffe.com/plugins/redirection/
I deactivated the plugin and the error went away.
My client has a lot of 301 redirects.
Any ideas on a fix?

March 29, 2013 at 8:50 am #70920

Anwar

I'm having the exact same problem. Suddenly the url is redirected to a child of the custom post type.

I also noticed that the other custom post type, to which the child is also attached, shows up when i create a repeating field.

It wasn;t there before and I can't seem to get rid of it, since it is not present in the custom field list of the child.

My setup:

Parent
Flight type 1, Flight type 2

Child
Flight options. This is a child of Flight type 1 and type 2

The permalink in the view of the Flights now redirect to one of the Options, instead of to the flight itself.

March 29, 2013 at 8:54 am #70921

Anwar

the select form at the right side is asking me to select a 'Hadj reizen', which is the other custom post type to which the child (flight option) is attached.

This wasn't there before and since it showed up, I think after updating Types, no URL is working anymore.

March 30, 2013 at 2:42 pm #71353

Anwar

Can we get an answer today? If this was happening on a live install I would be losing a lot of money, because all links to custom posts do not work.

April 1, 2013 at 12:57 pm #72169

Adriano
Forum moderator

Dear Users,

We found a bug and we are checking it now. You are notified when it's fixed, I will close this ticket temporarily. Thank you for your understanding.

April 9, 2013 at 12:06 pm #76459

Adriano
Forum moderator

@ Daniella and @Anwar,

We have investigated this and determined that the problem is with the redirect plugin. Would be nice if you could ask the maintainers of that plugin to fix it and report back the url of the support issue for Redirection plugin. We can then help the maintainers solve the problem.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

April 9, 2013 at 9:07 pm #76710

Daniella

I added it to the support forum. Thanks.

April 10, 2013 at 7:34 am #76901

Anwar

Thanks!

The strange thing is that the first thing I did was clear all the 301 redirects and de-activate the Redirection plugin, but the links were still not working.

After updating Types, reading this post and de-activating it again it does work.

@Daniella thanks for adding it to the Redirection plugin forum.

April 10, 2013 at 5:36 pm #77139

Adriano
Forum moderator

@Daniella and Anwar,

So, it works fine for both? Did you update the Redireciton plugin too?

April 10, 2013 at 5:55 pm #77148

Daniella

No, it does not work. I submitted a support thread on the Redirection plugin's support page and have not heard back.

April 11, 2013 at 8:47 am #77448

Anwar

No I still have the plugin disabled. Will not work with both plugins enabled.

I don't think the redirection plugin gets updated alot.

April 11, 2013 at 7:52 pm #77746

Adriano
Forum moderator

@Daniella and Anwar,

Thanks for the answer.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘[Closed] Post type with child relationship is redirecting’ is closed to new replies.


Support Policy
ToolSet staff will help you use Types, Views and CRED correctly, provide any information you need, help troubleshoot problems and advice on best-practices.
Please make sure to issue only one topic per each support ticket.
Need custom programming work for your site? Check out our certified partners.