[Closed] Author can't upload images

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will answer your ticket in about 5.59 hours from now. Thank you for your understanding.

Related documentation: Front-end Content Submission and Editing Forms

This topic contains 28 replies, has 2 voices, and was last updated by  Shane 2 weeks, 5 days ago. The support staff assigned to this topic is Shane.

Viewing 15 posts - 1 through 15 (of 29 total)
Author
Posts
#574204

When an author tries to edit a page on the frontend (it's using a CRED FORM for frontend page editing that I made), they can just fine. Then they press the INSERT MEDIA button and try to upload an image. It gives an error back "Sorry, you are not allowed to attach files to this post." Basically it won't let them upload anything.

In ACCESS, which is activated, I have authors set so they can upload files. What else can I try? Everyone else in user groups above them can upload images just fine.

#574262

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Thank you for contacting our support forum.

Does the author role have access permissions to the Media post type ?

If not then this could be what is causing the issue.

Thanks,
Shane

#574284

Yes they have these permissions for media: hidden link

#574288

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Could you enable these same permissions on the default CPT and let me know if the issue still remains.

Thanks,
Shane

#574289

Right now it is setup like this: hidden link Is this where you want me to change something? If so, what to what exaccly?

#574553

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Yes this is what I want you to change, also allow both to have publish permissions as well.

Thanks,
Shane

#574568

If this is what you meant to do: hidden link then it didn't work. Did you want me to try something else?

#574694

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

The Media type should have the same permissions as well.

Thanks,
Shane

#574703

I appreciate your help but what you are saying isn't making sense... that's why I keep asking. It's very vague. You now said the media type should have the same permissions but they are using the permissions from the default post type, which I changed. That change had no affect anything.

#574705

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Sorry for the vague answers.

Would you mind providing me with admin access to the website so that I can have a look at the issue and provide a more detailed response.

The private fields have been enabled for your next response. Also please let me know which form is having the issue.

Thanks,
Shane

#575885

I didn't seen any private field here. Just a normal reply field. Am I missing something?

#575886

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

It seems I didnt enable it.

Sorry it should be enabled now.

Thanks,
Shane

#576120

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Could you change the role of the user you gave me to an admin account.

Also if you disable the access plugin does it work ?

Please let me know.
Thanks,
Shane

#576135

Sure, I have done this for you. Just wanted you to see what author looked like when trying to add image.

I haven't tested the access thing.

#576227

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Mike,

Thanks for updating the permissions.

Would I be able to perform the access test ?

Thanks,
Shane

Viewing 15 posts - 1 through 15 (of 29 total)

The topic ‘[Closed] Author can't upload images’ is closed to new replies.