[Closed] Cannot stop using layouts for a page

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

This topic contains 9 replies, has 2 voices, and was last updated by  Nigel 1 month, 3 weeks ago. The support staff assigned to this topic is Nigel.

Viewing 10 posts - 1 through 10 (of 10 total)
Author
Posts
#525525

I am trying to: Stop using layouts for a page

When i open a page to edit it, and click 'stop using layout for this page', and choose any option in the popup, the button to submit is greyed out and I can't use the default editor at all. I'm not sure why layouts are even applying to pages, it seems to have done this after a recent update.

#525599

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

That's not something I have come across before.

Layouts 1.9 introduced the "Content Layout Editor" which, if you will, is a kind of Layouts-Lite used just to edit the post content area of individual posts and pages which works with most themes out-of-the-box and doesn't require the theme integration used for the full version of Layouts.

But it shouldn't do anything unless you actively use it. So on a page or post edit screen, there is an orange Content Layout Editor button. Without pressing it you would be using the normal post editor. Once you have pressed it you can use Layouts like a page builder to design the content, and only once you save that design will Layouts "take over" the post editor, which is the position you find yourself in now.

In your case did something happen differently than described above? You didn't edit your pages with the Content Layout Editor at any time but are now stuck using it?

Can you include your debug info in your next reply? https://wp-types.com/faq/provide-debug-information-faster-support/

#525683

Perhaps I accidentally clicked the orange button to switch to layout mode? I can't recall, but its possible. It doesn't explain why I can't get out of it though and revert to the normal editor?

#525697

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

Thanks for the debug info, which mostly looks in order.

I may need to take a copy of your site for testing, but before I do...

1. Does this happen just on one page or on all pages and posts?

2. Can you eliminate the possibility that this is caused by a conflict from one of your plugins or your theme? Switch to a default theme such as twentyseventeen and test again. And disable all non-Toolset plugins and test again.

Let me know what you find, and if that doesn't reveal anything I'll set up a private reply so I can get a copy of your site.

#525976

Hi, I've tested and have no issues with the theme, however the issue occurs when activating either plugin:

WP Member by Smart Media Pro
The Events Calendar by Modern Tribe

#526077

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Thanks for the info, I will test both of those plugins locally to see if I can reproduce the problem, and if so report the conflict to our developers.

I'll get back to you soon.

#526148

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

I tested and confirmed the issue with The Events Manager plugin and am reporting that to our developers so that the conflict can be identified and, hopefully, resolved.

There isn't a free version of WP Member available for me to test. Can I ask you to make a zipped copy of the plugin available at a URL such as dropbox so that we can test that, too?

I will mark your next reply as private so that you can share the URL and only I will see it. (You can ignore the template which asks for log-in credentials.)

#527038

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

Thanks for that. I have escalated this thread and passed the details on to second tier who are debugging the plugin conflict and I'll update you when there is some news to report.

#530317

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

This is a quick update to say that the issue has been identified and fixed by the developers and the fix will be available in the next Layouts release.

#555137

Nigel
Forum moderator

Supporter languages: English (English ) Spanish (Español )

Supporter Timezone: Europe/London (GMT+01:00)

Hi Natasha

A quick update to alert you that we published updates to our plugins yesterday which include the fix for this issue, so updating Toolset should now resolve the problem.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘[Closed] Cannot stop using layouts for a page’ is closed to new replies.

Known issues and their solutions

We document known issues and their solutions in Toolset erratas. Save time by checking there first and seeing if what you are facing is a known issue. This list is kept short. We do our best to resolve all known issues with every release of Toolset plugins.

Support Policy

Toolset staff will help you use the Toolset plugins correctly, provide any information you need, help troubleshoot problems and advice on best-practices.

Please make sure to issue only one topic per each support ticket.

For more information, read our full Customer Support Policy.

Need custom programming work for your site? Check out our certified partners.