[Waiting for user feedback] CRED User Edit Form Only Shows for Administrators on Frontend

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will answer your ticket in about 2.65 hours from now. Thank you for your understanding.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

Related documentation:

This topic contains 1 reply, has 2 voices, and was last updated by  Christian Cox 1 week, 5 days ago. The support staff assigned to this topic is Christian Cox.

Viewing 2 posts - 1 through 2 (of 2 total)
Author
Posts
#576963

I have setup a membership site that is in beta: http://niloadev.viewsamplesite.com/ and we have created a member edit profile page: http://niloadev.viewsamplesite.com/edit-member-profile/ - Here are my steps I performed:
1. Setup Custom Roles: NILOA Active and NILOA Provisional
2. Created Cred User Form (Edit) - Auto Generated Form
3. Set Allowed User Role for Admin, Editor, etc. and NILOA Active and NILOA Provisional
4. Went to Access Settings - CRED Forms and set "Edit Own Custom User with CRED Form" as true for both NILOA Active and NILOA Provisional (Even during further testing marked "Edit Others too"
5. Went to Access Settings - Types Fields - Set modify own fields and View Own fields in profile as true for both sets of the User Meta Fields Access
6. **I noticed in Access Settings - Post Types there is not Users in there but it is in another site that works fine
7. Added shortcode to the Edit Profile Page

ISSUE: Even though I updated all the permissions - If I use those 2 user roles and login or login with Editor, Contributor bascially If I login with any role that has the proper permissions the form is not on that page - nothing there. Only shows up if I login as Administrator.

P.S. On the Post Types Tab on Access Settings I am getting this error:
Warning: Illegal string offset 'everyone' in /home/niloadevviewsamp/public_html/wp-content/plugins/types-access/includes/Admin_Edit.php on line 1689

#577143

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-04:00)

Interesting, I downloaded your Duplicator clone and ran some tests. At first, I was having trouble accessing the Plugins page to disable / enable individual plugins. So I had to manually change the plugins directory name temporarily. That deactivated all the plugins. Then I was able to revert the folder name and reactivate individual folders. I noticed that Google Analytics was the core problem, so I disabled it. Then, I was able to see the edit member profile page form when logged in as a NILOA Active user, if I turn off all plugins except Access, CRED, Layouts, Types and Views. When I activated Membership 2 Pro, the form disappears but I can still see the page title "Edit Member Profile". Can you confirm the same behavior on your site?

Viewing 2 posts - 1 through 2 (of 2 total)

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.