[Resolved] Toolset Types breaks site when activating plugin

This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

Related documentation: WordPress Custom Post Types

This topic contains 13 replies, has 2 voices, and was last updated by  Jeffrey Veffer 2 months, 1 week ago. The support staff assigned to this topic is Beda.

Viewing 14 posts - 1 through 14 (of 14 total)
Author
Posts
#520751

I had an older version of Toolset Types installed but when I updated to the latest WP version [4.7.3]
updating to the most recent version of the plugin crashes the site. I don't get an error, just a white screen. I am using it in a multi-site environment. The main site is wellclientapp.com and there are several sites under it with the format name1.wellclientapp.com

I have repeated the behaviour several times. I have CMS Tree View, CRED Frontend Editor, and WP Views installed as well as others which support the application.

I created a new EC2 instance with up to date PHP and WordPress but when I active the Toolsets plugin, it still takes down the site with a 500 error.

I have deactivated all plugins via the CLI, then enabled them one at a time to find that Toolset Types is causing the white screen.

I am pretty sure that this plugin is the last one I need to finally get the site running properly (see the screen shot, when the plugin is not loaded)

Can you assist? Thanks!!

#520867

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

There must be an error, if there is a White Screen of Death.
Either you have to enable WP Debug, or you need to check the logs, in case you log the errors.

Then we can deduct what the issue is from the error statement.

Also, since you already seem to have done all the debug steps possible from within the admin, if above does not give any result, I will need a Site's Snapshot so I can debug it locally.
https://wp-types.com/faq/provide-supporters-copy-site/

Thank you

#521107

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

This errors are all due to the fact that you use outdated Plugins.

I see now you do not have any valid subscription for Toolset.

If you do, please register them and update them.

I can assist only Types problems here, and Types is not the issue on your site.
The problem are several customizations to WordPress and 2 fatals due to the PHP version (probably you use PHP 7+).
This 2 fatals are solved in every new Toolset Plugins version.

I tested your site with the latest Types and it works just great.
The rest are issues that you can only solve if you update Toolset (the fatals)
The issues due to custom coding in the WP Core files we cannot assist.

#521145

Thank you - I thought I had purchased this but I went ahead and purchased it now.
I checked the version (2.2.9) in the downloads area, but according to my WP install, I have the most recent version installed.
Is there a key that has to be installed?

#521360

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

Your duplicator shows me Types version 1.2 and the other Toolset also behind by several releases.

Types is free, there is no need to register it, and Toolset will also work if not registered, as long it's updated.

Was the issue resolved?
If not, please provide me Access to the site, and perform a Backup.

Please note, that I did remove all custom code on my local tests and also all plugins but toolset.
You got some plugins there that need special removal also in wp-config.
Furthermore, there were several customizations in the WP config file too, which I removed.

If I need to debug this on your site, it is needed to have a clean install.

Otherwise it will be very difficult to pin point the issue.

#522408

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

Well, I do not know what you have had sent me, but it was an old, outdated set of Plugins.

I dumped that local install as I do not need it anymore, the issue is resolved as described.

I requested Access to check that on your site, but I did not receive it.

Have you performed all those steps I outlined before we start to dig into Toolset on the live site?
This was locally resolved by basically avoiding all the customizations made on WordPress and updating our Plugins.

Thank you

#522884

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

I still see how all plugins are active, inclusive the Theme.

Also, Toolset on this site is very old. There is not even the new Admin Menu "Toolset".

You run:
- CRED Frontend Editor 1.4.2
- Views 1.11.1
- Types latest version

You need to update all those Plugins, and before you activate them, please disable the other plugins and use a native WordPress theme.
Please acknowledge that the Toolset Bootstrap Theme you use is deprecated.
You should use the Starter Theme instead.

Also, the PHP errors on your site (without Toolset) should be resolved first.
https://wp-types.com/account/downloads/

This will resolve the error.

#523538

Hi there!
I disabled all plugins and then activated CRED and Views for one of the sites (app.wellclientapp.com)
But when I activated Types, I got this error
Fatal error: Call to undefined method WPV_Settings::get_instance() in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/types/library/toolset/toolset-common/inc/toolset.settings.class.php on line 177

I am not sure where the conflict is occurring

Thanks!!

#523690

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

Views is still on version 1.11.1
So is CRED.

You cannot use those versions with the lateste Types and WordPress, they have been updated for some reasons.

Please update the plugins. Then activate Toolset Plugins only, and a native WordPress Theme.

This works just fine. Then, you can activate the other plugins and see where the issue is from.

I highly suggest to re-download all Toolset Plugins fresh, before you activate them.

You also have a warning on the Screen:

Notice: wpdb::escape is deprecated since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /opt/bitnami/apps/wordpress/htdocs/wp-includes/functions.php on line 3837

Not sure where that comes from, but it is not from Toolset.

#524356

Thanks.
I don't mean to be difficult but here is what I see when I check the versions of the plugins:

CRED Help (Version 1.4.2)

Documentation and Support

User Guides - everything you need to know about using CRED
Discover WP - learn to use CRED by experimenting with fully-functional learning sites
Support forum - online help by support staff

When I go to the Network Admin to update Types, it says I have the most recent version (see below)

Thanks for your help

#525116

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

OK.

CRED, currently, is at version 1.8.8

As I mentioned on your install all Plugins are out of date unless the Types one, which you updated.

You can find all latest Toolset Plugins here:
https://wp-types.com/account/downloads/

Please follow this manual process:
https://wp-types.com/documentation/installation/

This will solve the problems.

#525242

Thanks for the update
I have noticed that while I get update notifications for other plugins, for Toolset (e.g CRED, Views) I do not get update notifications, even as the plugins are out of date as you mentioned.

So I am hesitant to remove existing plugin (and data) then reinstall as I do not want to lose all the settings and data for them

Can you assist?

Thank you very much

#525598

Beda
Forum moderator

Supporter languages: English (English ) Spanish (Español ) German (Deutsch )

Supporter Timezone: Asia/Kuala_Lumpur (GMT+08:00)

As in the DOC I linked you can simply replace the FTP Files.

No data whatsoever will be lost, as this is all stored in the Database.

Nonetheless a backup is always reccommended before any sort of updates.

#525860

Thank you very much for helping me solve this.
Now the site works as before!

Viewing 14 posts - 1 through 14 (of 14 total)

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

Known issues and their solutions

We document known issues and their solutions in Toolset erratas. Save time by checking there first and seeing if what you are facing is a known issue. This list is kept short. We do our best to resolve all known issues with every release of Toolset plugins.

Support Policy

Toolset staff will help you use the Toolset plugins correctly, provide any information you need, help troubleshoot problems and advice on best-practices.

Please make sure to issue only one topic per each support ticket.

For more information, read our full Customer Support Policy.

Need custom programming work for your site? Check out our certified partners.