[Resolved] Twig git submodule interferes with local VCS

This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Our next available supporter will answer your ticket in about 7.12 hours from now. Thank you for your understanding.

Related documentation: Layouts Theme Integration

This topic contains 8 replies, has 3 voices, and was last updated by  heidiH 4 months ago. The support staff assigned to this topic is Shane.

Viewing 9 posts - 1 through 9 (of 9 total)
Author
Posts
#545753

I use Git to track all code (core, plugins, themes) in my WordPress install, and the repository is hooked into a CI server for deployment to dev, staging, and production servers.

When trying to activate the Layouts plugin on my dev server after a CI build, I got errors stemming from missing Twig library files. I finally tracked it down to the use of a Git submodule in the vendor library folder within the plugin. The submodule files were not pushed to my repository, and therefore didn't make it to the server.

I would not normally want to independently update a submodule that has not been tested with the plugin, but rather use the version that has been validated and packaged by you. In that regard, I don't think the layouts/vendor/twig/twig/.git folder should be in the official release.

Can advise on the expected handling of the submodule if this is intentional?

#545796

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Heidi,

Thank you for contacting our support forum.

I'm not sure why this is actually in your folders but I can check with our team to see why this is there and report to you the results.

Thanks,
Shane

#546149

Just bought and installed the Toolset. I'm having error messages referring to "layouts/vendor/twig" too ... just after activating the Layout module.

Warning: Wrong parameter count for class_alias() in ../wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/LoaderInterface.php on line 57

Warning: Wrong parameter count for class_alias() in ../wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 290

Warning: Wrong parameter count for class_alias() in ../public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Environment.php on line 1563

Warning: Wrong parameter count for class_alias() in ../public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/CacheInterface.php on line 58

Warning: Wrong parameter count for class_alias() in ../public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Cache/Null.php on line 40

Warning: Wrong parameter count for class_alias() in ../public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/ExtensionInterface.php on line 89

Warning: Wrong parameter count for class_alias() in ../public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Extension.php on line 67

Warning: Wrong parameter count for class_alias() in /public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1612

Warning: Wrong parameter count for class_alias() in /public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Extension/Escaper.php on line 112

Warning: Wrong parameter count for class_alias() in /public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Extension/Optimizer.php on line 35

Warning: Wrong parameter count for class_alias() in /public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/Extension/Staging.php on line 112

Warning: Wrong parameter count for class_alias() in /public_html/wp-content/plugins/layouts/vendor/twig/twig/lib/Twig/SimpleFunction.php on line 111

#546460

Problem seems solved after upgrading php to 7.1 and doing a reinstall.

#547489

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Gerard,

So that means you can close this one since the issue is resolved.

Thanks,
Shane

#547940

Can I, not being the 'issue-starter'?

#548453

Based on his description, Gerard's problem is very different from the one I originally reported. Please do follow up on the original question.

Thanks!

#548483

Shane
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/Jamaica (GMT-05:00)

Hi Heidi,

Regarding your issue our development team will be fixing this for a fureture update.

Thanks,
Shane

#549537

Thanks!

Viewing 9 posts - 1 through 9 (of 9 total)