[Closed] Type plugin services: all items – error 404

This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Our next available supporter will answer your ticket in about 7.17 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  Christian Cox 4 months ago. The support staff assigned to this topic is Christian Cox.

Viewing 4 posts - 1 through 4 (of 4 total)
Author
Posts
#546416

Hi,

I use the theme Moesia and have installed their demo content to build a quicke page.

Everything seems to work fine, except "Services".
“Add New” and “Categories” are okay, but when I click “All Items” an error message (404) appears. So I neither can update/change the demo-content, nor can I update my own newly added services.

Any idea why this doesn’t work? It's quite frustrating, as everything else is pretty easy to adjust.

Thanks,
Galatea

#546594

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Hi, can you share a download URL where I can find the demo content you are referring to? I downloaded content from their site, but it does not seem to include the "Services" custom post type.

Here are a couple of troubleshooting steps you can try:
- Resave your site's permalinks by going to Settings > Permalinks and clicking "Save". Retest.
- Temporarily disable non-Toolset plugins and enable a default theme like Twenty Seventeen. Retest.
- I would like to see if your WordPress installation is registering any errors. You can see how to enable debug logging here:
https://wp-types.com/documentation/user-guides/debugging-toolset/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);

Then add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
ini_set('display_errors', 'Off');

Then try to click the "All items" link again. This will create an error_log.txt file in your site's root directory. Please send me its contents. Once that is done, you can revert the updates you made to wp-config.php.

#549389

Hi Christian,

I finally found out the there is a conflict with Jetpack. I can't run both at the same time, which is pretty frustrating as I need both of them on the page. There is also an error message while updating pages when Jetpack is activated.

#549567

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

I finally found out the there is a conflict with Jetpack.
- Okay, so you're saying that if you disable Jetpack the problem is resolved?

There is also an error message while updating pages when Jetpack is activated.
- What is the error message?
- What "page" are you referring to - a WordPress Page post type, or a Service post, or something else?

I was able to find the demo content you were referring to here:
hidden link

I installed this demo content and activated the following plugins:
Jetpack 5.1
PageBuilder 2.5.8
SiteOrigin Widgets Bundle 1.9.3
Toolset Types 2.2.13
WP Importer 0.6.3

I'm not experiencing the same 404 error you mentioned here, and my list of Services shows up:
/wp-admin/edit.php?post_type=services

I'm also not experiencing an error when creating / editing a page, so I will need your help to understand the issue.
- Can you tell me what steps you took after installing the site demo content?
- Did you make any changes in the Jetpack settings?
- Are you using the latest version of Jetpack (5.1)?
- Can you follow the troubleshooting steps I outlined above and provide me with the error log so I can investigate further?

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘[Closed] Type plugin services: all items – error 404’ is closed to new replies.