[Resolved] I can add item to post field group & amend but once I save I can’t expand again

This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Our next available supporter will answer your ticket in about 5.53 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: In the post editor screen, I am unable to toggle custom field editing panels open or closed.

Solution: Check to see if the Field Styling Editor panel is enabled in wp-config.php. If it is enabled, disable it. This feature is being phased out in an upcoming release, and the code that supports it is being deprecated. Comment or delete this line:

define('TYPES_USE_STYLING_EDITOR', true);

Related documentation: Adding Custom Fields to WordPress

This topic contains 13 replies, has 2 voices, and was last updated by  Rachel 2 months, 1 week ago. The support staff assigned to this topic is Christian Cox.

Viewing 14 posts - 1 through 14 (of 14 total)
Author
Posts
#575793

I am trying to: Amend settings to currently saved post field group items but I can't expand any of the items. I've tried on various browsers.

Link to a page where the issue can be seen: hidden link

I expected to see: Expand/drop down ability for each item.

Instead, I got: No response when I click an item.

#575809

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Hi, could you please try these troubleshooting steps?
- Update your Toolset Starter theme to the latest version - 1.4.2. It's available in the account downloads area here on wp-types.com. Then log out, clear your browser cache, log back in and retest.
- Temporarily disable all non-Toolset plugins, log out, clear your browser cache, log back in and retest.
- If the problem was resolved, reactivate your other plugins one by one until the conflict is revealed.
- If the problem was not resolved, please open the browser console and look to see if any errors are displayed on this Post Field editor page.

Let me know the results and we can go from there.

#575977

I've gone through the plugins with no luck. I'll update the toolset starter theme later today when I have time to address any issues it might incur on the website. It's been so long since I created the site that I'm not sure what the implications will be. The site was showing an internal 500 error for a while this morning but we have since updated the PHP version to 7 which seems to have sorted that. I'll get back you soon and thanks 🙂

#576068

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Thanks, I will mark this ticket as pending your update. No need to reply right now, it will remain open for 30 days.

#576069

Thanks - I've updated the Toolset theme and I've also uninstalled and reinstalled types but with no luck. It's odd as there are other very similar installations on our server and so far this is the only one with this issue. I'm trying to find out what differences might occur in this installation which might point to the issue. Earlier I turned off all non-toolset plugins but with no luck either.

Do you any suggestions?

#576074

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Nothing offhand...may I access the wp-admin area to try this out and see if I notice anything strange? Private reply fields enabled here.

#576103

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Okay thanks, I can see what you're describing. This appears to be a conflict of some sort, though you mentioned before that disabling other plugins and using a default theme did not resolve the issue for you. So I think the best step for me to take next is to create a clone of your site so I can reproduce the issue locally and make changes to a copy without breaking your live site. I can install the Duplicator plugin to create the clone. Let me know if you approve and I will begin as soon as possible.

#576117

Yes please do feel free to install duplicator

#576127

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Okay I see the issue. There appears to be an error generated by the Fields Styling Editor module. As a test, can you please temporarily disable this on your site to see if the problem is resolved? In wp-config.php, please add a comment to this line:

/** Activate types style editor*/
//define('TYPES_USE_STYLING_EDITOR', true);

I will continue investigation to see what could be the problem here.

#576264

Hi there,

I commented out the line you mentioned and yes the pages worked as expected then. I have changed the wp-config.php file back to its original state now and it's stopped working again.

#576269

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

Okay, thanks. I've reached out to the team and it appears that this issue is known, and there's not a good solution for the Fatal Error. For now, the best approach is to disable Field Styling Editors by commenting out that line in your wp-config.php file. The Field Styles Editor will be phased out in a future release of Types.

Is there a specific field style you would like assistance with? I may be able to offer another solution to achieve the same results.

#576396

So are there any other implications of permanently commenting out the USE_STYLING_EDITOR.

Also, and forgive me for this, what is the field style editor? I've probably used it 1000 times but without knowing that's what it's called.

Thanks

#576691

Christian Cox
Forum moderator

Supporter languages: English (English )

Supporter Timezone: America/New_York (GMT-05:00)

This section is used for you to add custom styles that will determine how custom fields will be displayed in wp-admin when someone edits a post. If you have custom styles here already and turn off the style editor, those custom styles will go away and the default WP admin styles will be used. It should not affect anything on the front-end of the site, only in wp-admin.

See below - I've added a red border to the select tag in the style editor. The Field Group preview shows what this will look like in the wp-admin area when someone edits a post with this field group applied to the post type.

#576763

I've never really touched the field style editor I have to be honest but given that you're possibly going to phase it out anyhow that's probably for the best.

I can continue on as I need to now. Thanks ever so much for all your help Christian it really is much appreciated.

Hope you have a good weekend 🙂

Viewing 14 posts - 1 through 14 (of 14 total)